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Chapter 1 
Welcome to SAP2000 

SAP2000 represents the most sophisticated and user-friendly release of the 
SAP series of computer programs. When initially released in 1996, SAP2000 
was the first version of SAP to be completely integrated within Microsoft 
Windows. It features a powerful graphical user interface that is unmatched in 
terms of ease-of-use and productivity. Creation and modification of the model, 
execution of the analysis, and checking and optimization of the design, and 
production of the output are all accomplished using this single interface. A 
single structural model can be used for a wide variety of different types of 
analysis and design.  

Program Levels and Features 
The latest release of SAP2000 is available in four different analytical levels 
that all share the same graphical user interface: Basic, PLUS, Advanced, and 
Ultimate. 

All of these programs feature sophisticated capabilities, such as fast equation 
solvers, force and displacement loading, non-prismatic frame elements, 
tension-only braces, line and area springs, post-tensioning tendons, highly 
accurate layered shell elements, Eigen and Ritz modal analysis, multiple 
coordinate systems for skewed geometry, many different constraint options, the 
ability to merge independently defined meshes, a fully coupled 6-by-6 spring 
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stiffness, and the option to combine or envelope multiple dynamic analyses in 
the same run. 

The SAP2000 PLUS program adds unlimited capacity, moving load live-load 
analysis capabilities, a complete range of finite elements, frequency-domain 
analysis (both steady-state and power-spectral-density types) and time-history 
and buckling analysis options. Ground motion effects with multiple base 
excitations can be included. 

The SAP2000 Advanced level extends the PLUS capabilities by adding a 64-
bit based analysis engine (requires a 64-bit processor), a nonlinear link element 
(gaps, hooks, isolators, dampers, and multi-linear plasticity), a multi-linear 
plastic hinge for use in frame elements, a fiber hinge, a catenary cable element, 
a nonlinear shell element, and geometric nonlinearity. Analysis capabilities 
include static nonlinear analysis for material and geometric effects, including 
pushover analysis; and nonlinear time-history analysis by modal superposition 
or direct integration. 

The SAP2000 Ultimate level includes all of the nonlinear capabilities of the 
Advanced level and adds the following powerful features: 

 Staged construction, with time-dependent effects

 Offshore wave and wind loading

In general, the Advanced or Ultimate levels are required to perform nonlinear 
analyses, with the exception being that a nonlinear analysis may be run in any 
of the program levels for P-Delta analysis, and when using tension/ 
compression only frame members. 

All of the programs feature powerful and completely integrated design for 
steel, concrete, aluminum, and cold-formed steel, all available from within the 
same interface used to create and analyze the model. The design of steel and 
aluminum frame members features initial member sizing and iterative 
optimization. The design of concrete frame members includes the calculation 
of the amount of reinforcing steel required. Design stresses and tension 
reinforcing for concrete shells may also be displayed, calculated from the 
resolved tension-compression couple. Members can be grouped for design 
purposes, and a single mouse click on an element accesses the detailed design 
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calculations. A wide variety of the latest national and international design 
codes are supported, and more are being added all the time. 

All SAP2000 data, including model information, analysis results, and design 
results, can be accessed using a tabular data structure. Tabular data can be 
edited and displayed in the interface, or exported to a Microsoft Access 
database file, a Microsoft Excel spreadsheet file, or a simple text file. Data can 
be exported to create reports or to perform specialized calculations. This same 
tabular data can be imported into SAP2000, enabling models to be generated or 
modified outside SAP2000. Import and export capabilities also exist for other 
popular drafting and design programs. 

An Open Application Programming Interface (OAPI) is available for 
SAP2000. The OAPI provides developers of products for CADD and 3D 
modeling seamless and efficient access to all of the sophisticated analysis and 
design technology of SAP2000. Third-party developers can now create rich 
and tight two-way links with SAP2000, allowing for accurate transfer of 
models into SAP2000, complete control of SAP2000 execution, and extraction 
of analysis and design information from SAP2000, all from within their 
applications. The OAPI is compatible with most major programming 
languages, including Visual Basic Applications (VBA). Anyone familiar with 
Visual Basic programming should find the SAP2000 OAPI syntax easy and 
intuitive. 

The SAP name has been synonymous with state-of-the-art analytical solutions 
since the introduction of SAP, SOLIDSAP, and SAP IV more than forty years 
ago, followed by its implementation on the PC with SAP80 and SAP90. 
Building on this history of sophisticated numerical techniques, SAP2000 adds 
a tremendously easy and complete graphical user interface linked with 
powerful design capabilities. The result is an analysis and design program 
unequaled in efficiency and productivity that is used by thousands of 
engineering firms in more than one hundred countries. 
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Chapter 2 
Getting Started 

SAP2000 is a full-featured program that can be used for the simplest 
problems or the most complex projects. This chapter describes program 
installation and support options. 

Installing SAP2000 
Please follow the installation instructions provided in the separate 
installation document included in your SAP2000 Package, or ask your 
system administrator to install the program and give you access to it. 

If You are Upgrading... 
If you are upgrading from a previous version of SAP2000 (Version 11 
and earlier), you should be aware that there has been a significant change 
in nomenclature regarding loading: 

 The term "load pattern" replaces "load cases" of previous versions.

 The term "load cases" replaces "analysis cases" of previous versions.

 The term "load combinations" has not changed.
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These changes are being made consistently in all future releases of CSi 
products. These are simply changes in terminology; the concepts remain 
the same. 

Load patterns are spatial distributions of effects that act upon the 
structure, including forces, displacements, temperature, and the like. 
Load patterns by themselves do not produce any analysis results. Load 
cases define how load patterns are to be applied: statically or 
dynamically, linearly or nonlinearly, in what sequence, and so on. Load 
cases produce analysis results that can be displayed and output. The 
results of load cases can be combined in load combinations. Load 
combinations are used as the basis for design 

We recommend that new and experienced users alike read the remainder 
of this manual to familiarize themselves with SAP2000. Please also see 
the topic “SAP2000 Version 16 News” in the Help facility within the 
program to learn more about the new and improved features in SAP2000.  

About the Manuals 
This manual is designed to help you quickly become productive with 
SAP2000. The next chapter gives an introduction to the basic concepts of 
the graphical user interface and overall use of the program.  

The SAP2000 Introductory Tutorial manual is intended to provide first-
time users with hands-on experience using the modeling, analysis and 
design features of SAP2000.  

It is strongly recommended that you read this manual and work the 
tutorial before attempting a project using SAP2000. 

Additional information can be found in the on-line Help facility available 
within the SAP2000 graphical user interface, and in the other manuals 
supplied with the program. The manuals are available in Adobe Acrobat 
PDF format and can be accessed from within the program using the Help 
menu. They include the following: 

 CSi Analysis Reference Manual, containing information about
the advanced modeling and analysis features of the program
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 Various SAP2000 design manuals, containing detailed design
features specific to supported design codes

 SAP2000 Verification Manual, containing examples showing the
capabilities and verifying the accuracy of the analytical features
of the program

“Watch & Learn™ Movies” 
One of the best resources available for learning about the SAP2000 
program is the “Watch & Learn™ Movies” series, which may be 
accessed through the CSI web site at http://www.csiamerica.com. Those 
movies contain a wealth of information for both the first time user and 
the experienced expert, covering a wide range of topics from basic 
operation to complex modeling.  

CSi Wiki Technical Knowledgebase 
CSi maintains a Wiki page containing answers to frequently asked 
support questions as well as additional insights on program operation. 
This is a good first stop before contacting technical support because 
many of the most common, as well as some esoteric, questions are 
answered here. This page is fully indexed and searchable, and may be 
found at https://wiki.csiamerica.com.   

Technical Support 
Free technical support is available from Computers and Structures, Inc. 
(CSI) or your dealer via phone and e-mail for 90 days after the software 
has been purchased. After 90 days, priority technical support is available 
only to those with a yearly Support, Upgrade and Maintenance plan 
(SUM). Customers who do not have a current SUM subscription can 
obtain technical support, but via e-mail only and at the non-priority level. 
Please contact CSI or your dealer to inquire about purchasing a yearly 
SUM subscription. 

If you have questions regarding use of the software, please: 
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 Consult the documentation and other printed information
included with your product.

 Check the on-line Help facility in the program.

If you cannot find a solution, then contact us as described in the 
following sections. 

Help Us to Help You 
Whenever you contact us with a technical-support question, please 
provide us with the following information to help us help you: 

 The program level (Basic, PLUS, Advanced, or Ultimate) and
version number that you are using. This can be obtained from
inside the program using the Help menu > About SAP2000
command.

 A description of your model, including a picture, if possible.

 A description of what happened and what you were doing when
the problem occurred.

 The exact wording of any error messages that appeared on your
screen.

 A description of how you tried to solve the problem.

 The computer configuration (make and model, processor,
operating system, hard disk size, and RAM size).

 Your name, your company’s name, and how we may contact
you.

Phone Support 
Priority phone support is available to those with a current SUM 
subscription from CSI or your dealer. For users in North America, you 
may contact CSI via a toll call between 8:30 A.M. and 5:00 P.M., Pacific 
time, Monday through Friday, excluding holidays, at (510) 649-2200. 
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When you call, please be at your computer and have the program 
manuals at hand. 

Online Support 
Online support is available as follows: 

 Send an e-mail and your model file to support@csiamerica.com.

 Visit CSI’s web site at http://www.csiamerica.com and use the
Support link to submit a request for technical support.

If you send us e-mail, be sure to include all of the information requested 
in the previous “Help Us to Help You” section. 
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Chapter 3 
The Structural Model 

SAP2000 analyzes and designs your structure using a model that you 
define in the graphical user interface. The model consists primarily of the 
following types of components: 

 Units

 Objects

 Groups

 Coordinate systems and grids

 Properties

 Functions

 Load patterns

 Load cases

 Load Combinations

 Design settings

 Output and display definitions

3 - 1 
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The graphical user interface provides many powerful features to create a 
model. Start with a preliminary model, and then use the SAP2000 
design-optimization feature to refine the model with little effort. 

The topics in this chapter describe these components in a little more 
detail. 

Units 
SAP2000 works with four basics units: force, length, temperature, and 
time. The program offers many different compatible sets of force, length 
and temperature units to choose from, such as “Kip, in, F” or “N, mm, 
C.” Time is always measured in seconds (except for creep, shrinkage, 
and aging effects, which are measured in days). 

An important distinction is made between mass and weight. Mass is used 
only for calculating dynamic inertia and for loads resulting from ground 
acceleration. Weight is a force that can be applied like any other force 
load. Be sure to use force units when specifying weight values, and mass 
units (force-sec2/length) when specifying mass values. 

When a new model is started, SAP2000 will ask the user to specify a set 
of units. Those units become the “base units” for the model. Although 
input data may be provided and output data can be viewed in any set of 
units, those values are always converted to and from the base units of the 
model. 

Angular measure always uses the following units: 

 Geometry, such as axis orientation, is always measured in
degrees

 Rotational displacements are always measured in radians

 Frequency is always measured in cycles/second (Hz)
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Chapter 3 - The Structural Model 

Objects and Elements 
The physical structural members in the model are represented by objects. 
Use the interface to “draw” the geometry of an object, and then “assign” 
properties and loads to the object to completely define a model of the 
physical member. 

The following object types are available, listed in order of geometrical 
dimension: 

 Point objects, of two types: 

o Joint objects: Are automatically created at the corners or 
ends of all other types of objects, and they can be explicitly 
added to model supports or other localized behavior. 

o Grounded (one-joint) link objects: Are used to model 
special support behavior such as isolators, dampers, gaps, 
multi-linear springs, and more. 

 Line objects, of two types: 

o Frame/cable/tendon objects: Are used to model beams, 
columns, braces, trusses, cable, and tendon members. 

o Connecting (two-joint) link objects:  Are used to model 
special member behavior such as isolators, dampers, gaps, 
multi-linear springs, and more. Unlike frame/cable/tendon 
objects, connecting link objects can have zero length. 

 Area objects:  Are used to model walls, floors, and other thin-
walled members, as well as two-dimensional solids (plane stress, 
plane strain, and axisymmetric solids).  

 Solid objects:  Are used to model three-dimensional solids.  

As a general rule, the geometry of the object should correspond to that of 
the physical member. This simplifies the visualization of the model and 
helps with the design process. 
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If you have experience using traditional finite element programs, 
including earlier versions of SAP2000, you are probably familiar with 
meshing physical models into smaller finite elements for analysis 
purposes. Object-based modeling largely eliminates the need for that 
meshing. 

For users who are new to finite-element modeling, the object-based 
concept should seem perfectly natural. 

When an analysis is run, SAP2000 automatically converts the object-
based model into an element-based model that is used for analysis. This 
element-based model is called the analysis model, and it consists of 
traditional finite elements and joints (nodes). Results of the analysis are 
displayed on the analysis model. 

SAP2000 provides options to control how the meshing is performed, 
such as the degree of refinement, and how to handle the connections 
between intersecting objects. An option also is available to manually 
subdivide the model, resulting in a one-to-one correspondence between 
objects and elements. 

Groups 
A group is a named collection of objects. It may contain any number of 
objects of any number of types. Groups have many uses, including: 

 Quick selection of objects for editing and assigning. 

 Definition of incremental construction stages. 

 Definition of section cuts across the model. 

 Grouping objects that are to share the same design. 

 Selective output for grouped object. 

As many groups as needed can be defined. Using groups is a powerful 
way to manage larger models. 

3 - 4 Groups 



Chapter 3 - The Structural Model 

Coordinate Systems and Grids 
All locations in the model are ultimately defined with respect to a single 
global coordinate system. This is a three-dimensional, right-handed, 
Cartesian (rectangular) coordinate system. The three axes, denoted X, Y, 
and Z, are mutually perpendicular, and satisfy the right-hand rule. 

SAP2000 always considers the global +Z direction as upward. By 
default, gravity acts in the –Z direction. 

Additional coordinate systems can be defined to aid in developing and 
viewing the model. The systems are defined with an origin and 
orientation measured with respect to the global system. 

For each coordinate system (the global and all additional systems), users 
can define a three-dimensional grid system consisting of intersecting 
“construction” lines used for locating objects in the model. Each grid 
may be of Cartesian (rectangular), cylindrical, or general type.  

Drawing operations tend to “snap” to gridline intersections unless this 
feature is turned off.  The snap feature facilitates accurate construction of 
the model. When a grid line is moved, an option can be used to specify 
that the points in the model move with it. 

Each object in the model (point, line, area, and so forth) has its own local 
coordinate system used to define properties, loads, and response for that 
object. The axes of each local coordinate system are denoted 1, 2, and 3. 
Local coordinate systems do not have an associated grid. 

Properties 
Properties are “assigned” to each object to determine the structural 
behavior of that object in the model.  

Some properties, such as material and section properties, are named 
entities that must be defined before assigning them to objects. For 
example, a model may have the following properties: 
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 A concrete material property called 4000Psi. 

 A rectangular frame section property called RECT, and a circular 
section called CIRC, both using material 4000Psi. 

 An area section property called SLAB that also uses material 
4000Psi. 

If a user assigns frame section property RECT to a frame object, any 
changes to the definition of section RECT or material 4000Psi will 
automatically apply to that object. A named property has no effect on the 
model unless it is assigned to an object. 

Other properties, such as frame end releases or joint support conditions, 
are assigned directly to objects. These properties can only be changed by 
making another assignment of that same property to the object; they are 
not named entities and they do not exist independently of the objects. 

Functions 
Options are available to define functions to describe how load varies as a 
function of period or time. The functions are needed for certain types of 
analysis only; they are not used for static analysis. A function is a series 
of digitized abscissa-ordinate data pairs. 

Four  types of functions are available: 

 Response-spectrum functions: Pseudo-spectral acceleration vs. 
period for use in response-spectrum analysis. 

 Time-history functions: Loading magnitude vs. time for use in 
time-history analysis. 

 Steady-state functions: Loading magnitude vs. frequency for use 
in steady-state analysis. 
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 Power-spectral-density functions: Loading magnitude squared 
per frequency vs. frequency for use in power-spectral-density 
analysis.  

As many named functions as needed can be defined. Functions are not 
assigned to objects, but are used in the definition of load cases. 

Load Patterns 
Loads represent actions upon the structure, such as force, pressure, 
support displacement, thermal effects, ground acceleration, and others. A 
spatial distribution of loads upon the structure is called a load pattern. 

As many named load patterns as needed can be defined. Typically 
separate load patterns would be defined for dead load, live load, wind 
load, snow load, thermal load, and so on. Loads that need to vary 
independently, either for design purposes or because of how they are 
applied to the structure, should be defined as separate load patterns. 

After defining a load pattern name, assign specific load values to the 
objects as part of that load pattern. The load values assigned to an object 
specify the type of load (e.g., force, displacement, temperature), its 
magnitude, and direction (if applicable). Different loads can be assigned 
to different objects as part of a single load pattern. Each object can be 
subjected to multiple load patterns.  

For example, assume load patterns named WIND, SNOW, and SUN15 
have been defined. For load pattern WIND, different windward and 
leeward pressure loads could be assigned to vertical objects on opposite 
sides of the structure. For load pattern SNOW, downward forces might 
be assigned to roof objects only. For load pattern SUN15, different 
temperature values might be assigned to various objects in the structure 
to account for the effects of sun on the structure at 3:00 P.M. in the 
afternoon. 

To calculate any response of the structure caused by the load patterns, 
load cases must be defined and run (described in subsequent text) to 
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specify how the load patterns are to be applied (e.g., statically, 
dynamically, and so on) and how the structure is to be analyzed (e.g., 
linearly, nonlinearly, and so on). The same load pattern can be applied 
differently in separate load cases. 

In addition to the user defined load patterns discussed previously, 
SAP2000 also has three built-in acceleration loads that represent unit 
ground translational acceleration in each of the global directions. 
Acceleration loads are assigned automatically to all objects in the 
structure that have mass. 

Load Cases 
A load case defines how loads are to be applied to the structure, and how 
the structural response is to be calculated. Many types of load cases are 
available. Most broadly, load cases are classified as linear or nonlinear, 
depending on how the structure responds to the loading. 

The results of linear analyses may be superposed, i.e., added together, 
after analysis. The following types of load cases are available: 

 Static: The most common type of analysis. Loads are applied 
without dynamical effects. 

 Modal: Calculation of dynamic modes of the structure using 
eigenvector or Ritz-vector method. Loads are not actually 
applied, although they can be used to generate Ritz vectors. 

 Response-Spectrum: Statistical calculation of the response 
caused by acceleration loads. Requires response-spectrum 
functions. 

 Time-History: Time-varying loads are applied. Requires time-
history functions. The solution may be by modal superposition or 
direct integration methods. 

 Buckling: Calculation of buckling modes under the application 
of loads. 
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 Hyperstatic: Calculation of the secondary forces due to 
prestress forces and other self-equilibrating loads. 

 Moving Load: Calculation of the most severe response caused 
by vehicle loads moving along paths on the structure. Uses 
defined vehicle loads and defined paths rather than the load 
patterns used by other analysis types. 

 Multi-Step Static: Linear static analysis for multi-stepped load 
cases. A separate output step is produced for each step of the 
given loads. 

 Steady State: Harmonically varying loads are applied at one or 
more frequencies. Requires steady-state functions.  

 Power Spectral Density: Harmonically varying loads are 
applied according to a probabilistic specification of loading over 
a range of frequencies, and the expected value of the response is 
determined. Requires power-spectral-density functions.  

The results of nonlinear load cases normally should not be superposed. 
Instead, all loads acting together on the structure should be combined 
directly within the specific nonlinear load case. Nonlinear load cases 
may be chained together to represent complex loading sequences. The 
following types of nonlinear load cases are available: 

 Nonlinear Static: Loads are applied without dynamical effects. 
May be used for pushover analysis. 

 Nonlinear Staged Construction: Loads are applied without 
dynamical effects, with portions of the structure being added or 
removed. Time-dependent effects can be included, such as creep, 
shrinkage, and aging. 

 Nonlinear Time-History: Time-varying loads are applied. 
Requires time-history functions. The solution may be by modal 
superposition or direct integration methods. 
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Any number of named load cases of any type may be defined. When the 
model is analyzed, the load cases to be run must be selected. Results for 
any load case may be selectively deleted. 

Analysis results, when available, can be considered to be part of the 
model. They are needed to perform design. 

Load Combinations 
A SAP2000 combination, also called a “combo,” is a named combination 
of the results from one or more load cases or other combinations. When a 
combination is defined, it applies to the results for every object in the 
model. 

Five types of combinations are available: 

 Linear type: Results from the included load cases and combos 
are added linearly. 

 Absolute type: The absolute values of the results from the 
included load cases and combos are added. 

 SRSS type: The square root of the sum of the squares of the 
results from the included load cases and combos is computed.  

 Envelope type: Results from the included load cases and 
combos are enveloped to find the maximum and minimum 
values. 

 Range Add type: Positive values are added to the maximum and 
negative values are added to the minimum for the included load 
cases and combos, efficiently generating maximum and 
minimum responses for pattern loading. 

Except for the envelope type, combinations should usually be applied 
only to linear load cases, since nonlinear results are not generally 
superposable. 
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Design is always based on combinations, not directly on load cases. A 
combination that contains only a single load case can be created. Each 
design algorithm creates it own default combinations. Additional user-
defined combinations can be created for design or other purposes. Design 
may be performed for any arrangement of user-defined and program 
generated combinations. 

Design Settings 
The design features of the program can be used on frame objects whose 
section properties use materials of concrete, steel, cold-formed steel, or 
aluminum. Several settings can be made that affect the design of a 
particular model: 

 The specific design code to be used for each type of material, 
e.g., AISC-360-10 for steel, EUROCODE 2-2004 for concrete, 
AISI-ASD96 for cold-formed steel, and AA-ASD 2000 for 
aluminum. 

 Preference settings of how those codes should be applied to a 
model. 

 Combinations for which the design should be checked. 

 Groups of objects that should share the same design. 

 Optional “overwrite” values for each object that specify 
coefficients and parameters to change the default values in the 
design-code formulas. 

For steel, cold-formed steel, and aluminum design, the program can 
automatically select an optimum section from a user-defined list. The 
section also can be changed manually during the design process. As a 
result, each frame object can have two different section properties 
associated with it:  

 An “analysis section” used in the previous analysis, and 
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 A “design section” resulting from the current design. 

The design section becomes the analysis section for the next analysis, 
and the iterative analysis and design cycle should be continued until the 
two sections become the same. 

Although there are no explicit design settings for concrete shells, the 
program will display design stresses and the reinforcing contours 
necessary to carry the tensile force component of the resolved tension-
compression couple. This information is accessed under the Display 
menu for shells. The required reinforcing area is calculated using the 
rebar material type specified by the user under the Define menu.  

Design results for the design section, when available, as well as all of the 
settings described herein, can be considered to be part of the model.  

Output and Display Definitions 
The definition of the SAP2000 model and the results of analysis and 
design can be viewed and saved in many different ways, including: 

 Two- and three-dimensional views of the model. 

 Tables of values in plain text, spreadsheet, or database format. 

 Formatted documents containing tables of values in rich text and 
HTML format. 

 Function plots of analysis results.  

 Reports created by using a single command. 

 Reports customized using an advanced report writing feature. 

 Exports to other drafting and design programs. 

Options are available to save named definitions of display views, sets of 
output tables, document formats, and function plots as part of a model. 
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Combined with the use of groups, this can significantly speed up the 
process of getting results while developing the model. 

Learning More 
Each SAP2000 model is like a living thing that grows and changes as 
you develop it, run analyses, perform design, and review results. This 
chapter presented some of the basic features that make up a structural 
model, but to really understand the model you must also learn how to 
work with it. 

The next chapter describes how to use the SAP2000 interface to do just 
that. Basic concepts and techniques will be presented. To put all this 
information together, we recommend that you read and perform the 
tutorial example given in the SAP2000 Introductory Tutorial manual, 
included in this volume. 

You can learn more about the details of using the graphical user interface 
by using the Help facility within the interface itself. Information about 
the SAP2000 model is also available in the Help facility. 
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Chapter 4 
The Graphical User Interface 

The SAP2000 graphical user interface is used to model, analyze, design, 
and display the results for your structure. This chapter introduces some 
of the basic concepts of the graphical user interface and sets the stage for 
the tutorial described later in this volume. More advanced concepts and 
features are described in the on-line Help facility of the graphical user 
interface itself. 

Please first read the previous chapter, “The Structural Model,” because 
all operations described in this chapter are used in working with a 
SAP2000 model. 

The SAP2000 Screen 
After starting the program, the SAP2000 graphical user interface appears 
on your screen and looks similar to the figure on the next page. The 
various parts of the interface are labeled in the figure and are described 
as follows. 

Main Window 
Figure 4-1 shows the main window for the graphical user interface. This 
window may be moved, resized, maximized, minimized, or closed using 
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standard Windows operations. The main title bar, at the top of the main 
window, gives the program name and the name of the model file. 

 
Figure 4-1 The Graphical User Interface Main Window 

Menu Bar 
The menus on the Menu Bar contain almost all of the operations that can 
be performed using SAP2000. Those operations are called menu 
commands, or simply commands. Each menu corresponds to a basic type 
of operation. The operations are described later in this chapter. 

Throughout this manual, and in the SAP2000 help facility, menu 
commands are indicated as Menu > Command, where “Menu” is the 
menu name, and “Command” is an item you can select from the menu. In 
some cases, commands are on sub-menus of the main menu, in which 
case they are indicated as Menu > Sub-menu > Command. 

Active Display 
Window 

Display 
Window 

Status Bar 

Toolbars Main Title Bar 
Display Tab 

Current Units 

Coordinate System 

Cursor Coordinates 

Menu Bar 

Active Display 
Window 

Display 
Window 

Status Bar 

Toolbars Main Title Bar 
Display Tab 

Current Units 

Coordinate System 

Cursor Coordinates 

Menu Bar 

Window List 
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Toolbars 
The buttons on the toolbars provide quick access to many commonly 
used operations. Move the mouse cursor over one of these buttons and 
the name of the button will display, indicating the associated command, 
as shown in Figure 4-2. 

 

Most buttons correspond to menu commands. If a menu command has a 
corresponding button, it will be displayed next to the command on the 
menu, as shown in Figure 4-3. The association of the button with the 
menu command is intended to help you recognize and remember which 
buttons can be used to perform the same actions as the commands. 

 

Move the toolbars around to any of the four sides of the main window, or 
have them float over the display windows by dragging them to the 

Figure 4-2 Roll over 
tool tip, indicating the 
Draw Frame/Cable 
command 

Figure 4-3 Menu 
Commands with 
Corresponding Buttons 
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desired location. Also control which toolbars are present by right 
clicking on the menu bar and selecting the toolbars to display. Choose 
the buttons on the toolbars by clicking the down arrow and selecting the 
buttons. Use these methods to create custom toolbars of frequently used 
operations. 

Display Windows 
Display windows show the geometry of the model and may also include 
properties, loading, analysis or design results. From one to four display 
windows may be shown at any time. 

Each window may have its own view orientation, type of display, and 
display options. For example, an undeformed shape could be displayed in 
one window, applied loads in another, an animated deformed shape in a 
third, and design stress ratios in the fourth window. Alternatively, four 
different views of an undeformed shape or other type of display can be 
shown: a plan view, two elevations, and a perspective view. 

Only one display window is “active” at a time. Viewing and display 
operations only affect the currently active window. Make any display 
window active by clicking on its display tab or within the window. 

Status Bar 
The status bar contains the following items: 

 Status information about what the program is currently doing, or 
the number of objects currently selected.  

 The coordinates of the mouse cursor. 

 A drop-down list to show or change the current units. 

 A drop-down list to show or change the current coordinate 
system. 
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 Scrolling controls when displaying analysis results for multi-step 
cases. 

 Animation controls when displaying deformed shapes. 

Using the Mouse 
The left and right mouse buttons have different functions depending on 
the location of the mouse in the graphical user interface. 

In the menu and toolbar areas, the mouse buttons have the following 
functions: 

 Left button 

o Select commands from the menus or toolbar buttons. 

o Move the toolbars around. 

 Right button: Customize the toolbars. 

Clicking either mouse button in a display window makes that window 
active. Within a display window, the mouse buttons have the following 
functions: 

 Left mouse button, depending on the program mode (i.e., Draw 
or Select  node):  

o Draw new objects. 

o Select existing objects. 

o Perform graphical operations such as pan, zoom, and 
rotate. 

 Right mouse button:  

o When clicked on an object, this button accesses 
information about the object. Objects may be edited by 
double clicking (left mouse button) on items in the 
object information form. 
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o When clicked on the background, this button accesses a 
menu of operations. 

Elsewhere in the interface, the mouse buttons have standard Windows 
functions. This includes when on the main title bar, the status bar, and in 
all forms. 

Viewing Options 
Various view options for the active Display Window can be set to control 
how the structure appears in that window. Those options are available on 
the View menu. View options are set independently for each Display 
Window. 

2-D and 3-D Views 
A 2-D view consists of a single plane or surface. Only objects in that 
plane or surface are visible. The out-of-plane coordinate of the view can 
be changed at any time. Default 2-D views are available at grid points in 
the current coordinate system. Other 2-D views, such as developed 
elevations, can be user created. 

A 3-D view shows the entire model from a user selected vantage point. 
Visible objects are not restricted to a single plane. The view direction is 
defined by an angle in the horizontal plane and an angle above the 
horizontal plane. 

Perspective 
A 3-D view may be toggled between a perspective view and an 
orthographic projection. The perspective view is usually better for 
visualizing the third, out-of-plane, dimension. If perspective is turned on 
for a 2-D view, the view becomes 3-D until perspective is turned off 
again. 

Set the perspective aperture angle to specify the distance of the view 
from the structure. The larger the angle, the closer the view to the 
structure, and the more distorted the view of the structure may appear. 
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Pan, Zoom, and 3-D Rotate 
Zoom-in to a view to see more detail, or zoom-out to see more of the 
structure. Zooming in and out may be performed in predefined 
increments. Also, zoom in on a part of the structure using the mouse by 
dragging a window around the area of interest while holding down the 
left mouse button. 

Panning allows the structure to be moved dynamically around the 
Display Window by holding down the left mouse button while dragging 
the mouse in the window. 

Use the 3-D Rotate command to dynamically rotate the structure by 
holding down the left mouse button while dragging the mouse in the 
window. 

Limits 
Upper and lower X, Y, and Z coordinate limits can be set to restrict the 
portion of the structure that is visible in a Display Window. Zooming and 
panning apply only to the part of the structure within these limits. 

Set Display Options 
The types of objects present in a Display Window can be controlled. 
Also various options can be set to affect how the objects appear and what 
features are displayed, such as object labels, property labels, and local 
axes. These options primarily affect views of the undeformed shape.  

Only objects that are present in a Display Window can be selected 
graphically. See the selection operations described later in this chapter. 

Objects may be shown by edges, area fill, or as 3-D shaded images. They 
can be colored according to their type, section properties, material 
properties, or groups. 

The shrunken-object view is an important option. It shrinks the objects 
away from the joints, allowing better viewing of the connectivity of the 
model.  
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In addition to the object model, the analysis model, which shows the 
model at the element level, may be viewed at any time. The analysis 
model shows how the program has automatically meshed the structure. 
Results are always shown on the analysis model, rather than on the 
object model. 

Other Options 
Other options can be used to turn gridlines and the global axes on and 
off. The view parameters can be saved under a user-specified name and 
recalled later to apply to any Display Window. 

Refreshing the Display Window 
After performing certain operations, the Display Window may need to be 
re-drawn. Normally this occurs automatically, although a command on 
the Options menu can be used to turn this feature off to save time when 
working with large models. When the feature is turned off, use the View 
menu > Refresh Window command to update and redraw the active 
display window. 

Basic Operations 
It will be helpful to understand the basic types of operations that can be 
performed using SAP2000. The program responds differently to mouse 
actions in the Display Windows depending on the type of operation 
being performed.  

The remainder of this chapter provides an overview of SAP2000 
operations. Details on how to actually perform these operations are given 
in the quick tutorial in the next manual, and in the on-line Help facility of 
the graphical user interface itself. 
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File Operations 
File operations are used to start a new model, to bring in an existing 
model for display or modification, to save the current model, and to 
produce output. File operations are selected from the File menu. 

New models can be started from scratch or from pre-defined templates 
supplied with the program. 

A model and its results can be saved as a standard SAP2000 binary file 
(.SDB extension), and opened again later to review results or make 
further changes.  

Alternatively, a model and its results can also be exported, in whole or in 
part, to a text file, a spreadsheet file, or a database file using SAP2000 
tabular data format. Models can be imported using SAP2000 tabular data 
format, whether the data file (text, spreadsheet, or database) was 
previously exported from the graphical user interface, or created 
externally in some other way. 

Model geometry can be exported to and imported from AutoCAD and 
other programs that use .DXF, IFC, or .IGES file formats. Similar 
import/export capabilities are available for the ProSteel and FrameWorks 
Plus packages. SAP2000 can also share information with steel detailing 
programs using CIS/2 Step or Steel Detailing Neutral File formats and 
import/export project data with Autodesk Revit Structure. 

The model description and the results of analysis and design can be 
printed in simple tables or produced in custom reports that include 
graphics, text, and formatting features. The active display window can be 
printed as graphics or saved in bitmap and enhanced Windows metafile 
formats. Video files can be created showing animated mode shapes or 
time-history deflected shapes. 

Other file operations include defining project information for the 
particular model; maintaining a detailed log of the project; and a facility 
for running the analyses of multiple models in batch mode. 

 File Operations 4 - 9 



SAP2000 Getting Started 
 

Defining Named Entities 
Defining is used to create named entities that are not part of the geometry 
of the model. These entities include: 

 Object properties, such as 

o Material properties 

o Frame, Tendon, Cable, Area, Solid, and Link properties 

o Hinge properties 

 Coordinate/grid systems 

 Joint constraints 

 Object groups 

 Load-related items, such as 

o Joint patterns, for temperature and pressure loading 

o Load patterns 

o Mass source 

o Moving load loads (vehicles and paths) 

o Response-spectrum and time-history functions 

 Analysis and response items, such as 

o Load cases 

o Load combinations 

o Generalized displacements 

o Section cuts 

o Pushover Parameters 

 Output and display items, such as 
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o Named views, for display window settings 

o Named sets, for output and export definition 

Defining these entities is performed using the Define menu and does not 
require a prior selection of objects. 

Object properties, groups, and some of the loading can be assigned to 
selected objects. Many of these entities can also be defined during the 
assignment operation from the Assign menu. 

The remaining entities apply to the model as a whole and are not 
assigned to objects. 

Drawing  
Drawing is used primarily to add new objects to the model or to modify 
objects one at a time. Objects that can be drawn include points (joints 
and grounded links), lines (frames, cables, tendons, and connecting 
links), and areas (shells, planes, asolids). Solid objects are not drawn, but 
are created by extrusion; see the subsequent “Editing” section for more 
information about extrusion. 

Joints are created automatically at the ends of line and link objects and at 
the corners of area and solid objects. Additional joints may be added 
explicitly. Duplicate joints and objects at the same location are 
eliminated automatically by the program, except that duplicate link 
objects are permitted as an option. 

To draw, enable the Draw Mode by selecting one of the object drawing 
commands from the Draw menu. While drawing, a form will float over 
the display windows. The form has drawing controls and property 
options that can be assigned while drawing. The form can be moved or 
closed if it is in the way while drawing.  

Draw Mode and Select Mode are mutually exclusive. To return to Select 
Mode, use the Draw menu > Set Select Mode command, or perform any 
selection operation. While drawing, the left mouse button can be used to 
zoom, pan, or rotate, after which the program will return to draw mode.  
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Drawing Objects 
Use the left mouse button to perform drawing operations. Depending on 
the drawing operation, click, double-click, or click-and-drag the left 
mouse button (hold down the left button while moving the mouse): 

 Draw Special Joint – Click once to draw a joint, or drag a 
window to draw joints at all enclosed grid intersections 

 Draw Frame/Cable/Tendon – Click once to draw each end point 
in a series of objects connected end-to-end, then double click to 
end the series 

 Quick Frame/Cable/Tendon – Click once on a grid segment to 
draw an object, or drag a window to draw objects on all enclosed 
grid segments 

 Quick Draw Braces – In a 2-D view, click in a grid space (bay) 
to draw diagonal braces 

 Quick Draw Secondary Beams – In a 2-D plan view, click in a 
grid space (bay) to draw a set of secondary beams (frame 
objects) 

 Draw Poly Area – Click once at each corner location to draw a 
polygon – hit the enter key to end the drawing 

 Draw Rectangular Area – In a 2-D view, click once at two 
opposite corners to draw the object 

 Quick Draw Area – Click in a grid space (bay) to draw an area 
object, or drag a window to draw objects on all enclosed grid 
spaces 

 Draw 1 Joint (Grounded) Link – Click once to draw a grounded 
link, or drag a window to draw grounded links at all enclosed 
grid intersections 

 Draw 2 Joint (Connecting) Link – Click once to draw each end 
point in a series of objects connected end-to-end, then double 
click to end the series 
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 Quick Draw 2 Joint (Connecting) Link – Click once on a grid 
segment to draw an object, or drag a window to draw objects on 
all enclosed grid segments 

 Reshape objects – Click once on an object to be reshaped, then 
click and drag the part of an object to be moved to achieve the 
new shape 

In 3-D views, cursor placement is limited to known locations, such as on 
gridlines and at existing point objects. In 2-D views, cursor placement 
can be anywhere, since the third (out-of-plane) dimension is known.  

Cursor movements can be controlled using “snap” and  “drawing 
control” tools during drawing and reshaping of objects.  

Snap Tools 
Snap tools find the closest snap location to the pointer as the pointer is 
moved over the model. The snap tools are a fast and accurate way to 
draw and edit objects. The snap tools can be turned on and off as objects 
are drawn. More than one snap tool can be turned on at the same time. 
Options include snapping to the following: 

 Point objects and grid intersections 

 Object ends (corners) and midpoints (mid-edges) 

 Object intersections 

 Perpendicular projection to a line object or the edge of an area or 
solid object 

 Line objects and the edges of area and solid objects 

 Fine grid, an invisible, three-dimensional grid of user-defined 
uniformly spaced points 
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Drawing Controls 
In 2-D views, the drawing control tools provide the capability to enforce 
the placement of a point along specified lines that pass through the last 
drawn point. Drawing controls include: 

 Horizontal H – The line is drawn parallel to the axis that 
appears horizontal in the 2-D view. 

 Vertical V – The line is drawn parallel to the axis that appears 
vertical in the 2-D view. 

 Parallel to Angle A – The line is drawn at a constant angle to 
the axis that appears horizontal in the 2-D view. 

 Fixed Length L – The line is drawn at a constant length, 
measured in the 2-D view. 

 Fixed Length and Angle S – The line is drawn at a constant 
angle and a constant length, measured in the 2-D view. 

 Fixed dh and dy D – The line is drawn at constant lengths along 
the axes that appear horizontal and vertical in the 2-D view. 

Select drawing controls from the floating properties of object form that 
appears while drawing, or press the corresponding letter key (“H”, “V”, 
“A”, etc.) on the keyboard. Pressing the space bar on the keyboard 
cancels the drawing control. 

The snaps options can be used in conjunction with drawing controls. 
Only the unconstrained component of the selected snap point is used 
when a control has been selected. 

Selecting 
Selecting is used to identify existing objects to which the next operation 
will apply. 

SAP2000 uses a “noun-verb” concept where first a selection of objects is 
made, and then an operation is performed upon them. Operations that 
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require prior selection include certain Editing, Assignment, Design, 
Display, and Output operations. 

To select, enable the Select Mode using the Draw menu > Set Select 
Mode command, or by choosing any command from the Select menu. 
Draw Mode and Select Mode are mutually exclusive. Any operation 
except drawing can be performed when the program is in Select Mode. 

Select objects graphically or by various features of the objects. Selection 
operations are cumulative, i.e., each selection operation adds objects to 
the current set of selected objects, and each deselection operation 
removes objects from the set. 

Selected objects are shown graphically in the display windows with 
dashed lines. The number of selected objects of each type is shown in the 
status bar. It is always a good idea to check the status bar when 
performing selection operations. 

After the selection set has been created (the “noun”), an operation is 
performed (the “verb”) upon it. This then clears the selection, and the 
program is ready to start a new selection for the next operation. 

Four important selection commands are available from the menu or the 
toolbar: 

 Select menu > Select > All command selects every object in the 
model, regardless of what objects are shown in the display 
windows. 

 Select menu > Get Previous Selection command selects the 
same objects as in the last completed selection operation. 

 Select menu > Invert Selection command selects all objects not 
currently selected. 

 Select menu > Clear Selection command deselects all objects. 

Other selection (and deselection) operations are described in the 
following sections. 
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Selecting Graphically 
Objects can be selected (or deselected) graphically using the left mouse 
button in a display window. Several types of graphical selection are 
available: 

 Select by pointer – Click on an unselected object to select it, or 
click on a selected object to deselect it. 

 Select by enclosing window – Drag a window from left to right 
to select all objects that are fully enclosed in the window. 

 Select by intersecting window – Drag a window from right to 
left to select all objects that are fully or partially enclosed in the 
window. 

 Select by polygon – Draw a polygon with any number of sides to 
select all objects that are fully enclosed in the polygon. 

 Select by intersecting polygon – Draw a polygon with any 
number of sides to select all objects that are fully or partially 
enclosed in the polygon. 

 Select by intersecting line – Draw a line with any number of 
segments to select all objects that are intersected by the line 
segments. 

 Select by 3-D box – Click on two points in a 3-D view to select 
all objects enclosed within a box whose diagonal is defined by 
the two points and whose sides are parallel to the X, Y, and Z 
axes. 

The first three options are available by default and are indicated by the 
usual pointer cursor. The last four options require that the type of 
selection be set using the Select menu or the toolbar. After a single 
selection, the cursor returns to the default pointer/window selection 
mode. 

Only objects displayed in a given window can be selected graphically. 
For example, assume a model includes point, line, and area objects, but 
only area objects are displaying in a particular window. If a selection is 
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made by dragging a window around the entire structure, only area objects 
will be selected, even if hidden point and line objects actually exist 
inside the selection window. 

While selecting by pointer, use the left mouse button to zoom, pan, or 
rotate, after which the program will return to select mode. 

Selecting by Feature 
From the Select menu, select or deselect objects by their various features, 
such as: 

 All objects on a particular plane 

 All objects that have a given section or property type 

 All line objects parallel to a particular line 

 All line objects parallel to a particular axis or plane 

 All objects that belong to the same group 

 All point objects that have a specified support or constraint 

 All objects that have specified labels 

These selection methods, except for selecting line objects parallel to 
another line, operate independently of the display windows and affect all 
objects having a given feature even if those objects are not being 
displayed. 

The use of groups is particularly helpful when making complicated 
selections. If the same set of objects is likely to be selected more than 
once, build the selection set and then assign a group name to the selected 
objects. After a Group Name has been assigned, the selection set can be 
reselected using the Group Name. 

Selecting by Coordinates 
From the Select menu, select or deselect objects by specifying the 
coordinate range of a volume. The coordinate range is identified using 
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one of the following four methods for each of the three coordinate 
system directions (X, Y and Z): 

 Not limited 

 Between two values 

 Outside of two values 

 At a single value 

An option exists to signify whether the entire object must lie within the 
volume in order to be selected, or only partially inside. 

Selecting using Tables 
From the Select menu, select or deselect objects using connectivity and 
object assignment database tables. Tables may be filtered and sorted by 
field, and individual records or the entire table can be selected. 

Editing 
Editing is used to make changes to the model. Most editing operations 
work on a prior selection of objects. The following editing operations, all 
selected from the Edit menu, can be used: 

 Cut or Copy the geometry of selected objects to the Windows 
clipboard. Geometry information put on the clipboard can be 
accessed by other programs, such as spreadsheets. 

 Paste object geometry from the Windows clipboard into the 
model. This could have been edited in a spreadsheet program 
from a previous Cut or Copy. 

 Delete selected objects. 

 Replicate selected objects in a linear or radial array. 

 Move selected objects to a new location. 

 Extrude selected objects to create higher dimensional objects: 
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o Extrude points to lines 

o Extrude lines to areas 

o Extrude areas to solids. This is the only way to 
graphically create solid objects. 

 Divide selected objects into smaller objects of the same type. 

 Connect or disconnect selected objects at a common joint. 

 Add to the model from a template. 

 Interactively edit the model in tabular data format. 

 Change labels of objects and other named entities. 

Pasting and adding to the model from a template do not operate on a 
selection of objects. Interactive table editing and changing labels can 
work on a selection or the entire model. All other operations require a 
prior selection to be made. 

Assigning 
Properties and loads are assigned to one or more selected objects. 
Assignment operations are selected from the Assign menu, including: 

 Assigning properties to joint objects, including restraints, 
constraints, springs, masses, and local coordinate systems 

 Assigning properties to frame/cable/tendon objects, including 
section properties, end releases, local coordinate systems, end 
offsets, insertion points, output locations, nonlinear properties, 
line springs and masses, automated meshing parameters, and 
more  

 Assigning properties to area objects, including section 
properties, local coordinate systems, area springs and masses, 
automated meshing parameters, and more  
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 Assigning properties to solid objects, including section 
properties, local coordinate systems, surface springs, automated 
meshing parameters, and more 

 Assigning properties and local coordinate systems to link objects 

 Assigning loads of many different types to each type of object 

 Assigning pattern values to joints for use in defining temperature 
and pressure loads 

 Assigning group names to objects, making the objects part of 
that group 

 Copying assignments from one selected object, and in a separate 
operation, pasting these assignments onto one or more selected 
objects of the same type 

Undo and Redo 
SAP2000 remembers all drawing, editing, and assignment operations 
performed. It is possible to Undo a series of actions previously 
performed. If the Undo process is overused, actions may begin to Redo. 
Undo and Redo are accessed from the Edit menu.  

Important notes:  

 Undo does not apply to define operations. 

 Undo does not apply to interactive table editing. 

 After a model has been saved, an analysis has been run, or 
interactive table editing has been performed, prior operations can 
not be undone. 

Analyzing 
After a complete structural model has been created, analyze the model to 
determine the resulting displacements, stresses, and reactions due to the 
loads applied in the load cases. 
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Before analyzing, set analysis options from the Analyze menu. Those 
options are as follows: 

 Set available degrees of freedom for the analysis, which are 
primarily used to restrict a model to planar behavior 

 Set whether the model definition and analysis results should be 
automatically saved in SAP2000 tabular format to an Access or 
Excel file 

Before running the analysis, an analysis model may be created. After the 
analysis model has been created, it may be shown in a Display Window 
to review how the model has been meshed from the object model drawn 
by the user.  

Run Analysis 
To run the analysis, use the Analyze menu > Run Analysis command 
and select which cases are to be run. Any cases that have been run 
already do not need to be run again. Any cases that are not run can be run 
later.  

If a load case that requires results from another case is chosen, the 
prerequisite case will be run first if it has not been already. For example, 
if a response-spectrum case is run, the case that defines the modes will 
also be run if needed. 

Before running the analysis, SAP2000 saves the model. During the 
analysis, messages from the analysis engine appear in a monitor window. 
When the analysis is complete, review the analysis messages using the 
scroll bar on the monitor window. Click on the OK button to close the 
monitor window after reviewing those messages. The messages are also 
saved in a file with extension .LOG, which can be viewed later using the 
File menu > Show Input/Log Files command. 

No other SAP2000 operations may be performed while the analysis is 
proceeding and the monitor window is present on the screen. However, 
other Windows programs can be run during this time.  
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Model-Alive Feature 
To run the analysis automatically, in a continuous manner, use the 
Analysis menu > Model-Alive command. This analysis mode allows the 
user to make revisions to a model and have the model analysis updated 
automatically without first having to save the model and then execute the 
run command. The Model-Alive feature can be especially useful on 
smaller models because it allows the user to instantly see the effects of 
any model revision. The Model-Alive feature will not be as beneficial 
on larger models with longer run times. 

The SAP2000 model is not automatically saved when running the 
analysis in the Model-Alive mode. The File menu > Save command 
can be used at any time to save the model; otherwise, the model remains 
unlocked and unsaved. 

Displaying 
Displaying is used to view the model definition and analysis results. 
Graphical displays, tabular displays, and function plots are all available. 
All display types may be chosen from the Display menu, except that 
displaying of design results is performed using the Design menu. 

Graphical Displays 
A different type of graphical display may be selected for each Display 
Window. Each window may also have its own view orientation and 
display options. 

Model Definition 
View the model geometry using the Display menu > Show 
Undeformed Shape command. This displays only the objects and 
assignments that are chosen using the View menu > Set Display 
Options command. All other assignments to the objects may be viewed 
using the Display menu > Show Load Assigns and Display menu > 
Show Misc Assigns commands. 

4 - 22 Displaying 



Chapter 4 - The Graphical User Interface 
 

When viewing the undeformed shape, with or without assignments, a 
right click with the mouse on any object accesses an information form 
showing all the details of geometry, connectivity, assignments, and loads 
for that object. An object may be edited from within an information form 
by double-clicking in an edit box. 

Analysis Results 
Analysis results can be graphically displayed for any case that has been 
run. Those displays include the following: 

 Deformed shapes 

 Reactions and spring forces for joints 

 Force and moment diagrams for frames, cables, and links 

 Force and moment stress-resultant contour plots for shells 

 Stress contour plots for planes, asolids, and solids 

 Design stresses for concrete shells 

 Influence-lines for displacements, reactions, spring forces, and 
forces and moments in all object types 

 Virtual work plots for all object types 

Deformed shapes can be animated using the controls on the status bar. 
Animating the deformed shape sometimes helps to clarify the behavior of 
the structure. 

For load cases with multiple results (multiple modes or multiple steps), 
use the scrolling controls on the status bar to step through the individual 
results. An option is available to plot the maximum or minimum over 
multiple steps. 

Details of the displayed results can be obtained by clicking on an object 
with the right mouse button. 
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Named Displays 
The display showing in the active window can be saved using the 
Display menu > Save Named Display command. This named display 
includes the view orientation and scaling, view options, as well as the 
contents of the display:  undeformed shape, deformed shape, element 
forces/stresses, assignments and so on. A named display can be 
referenced and included in a printed report. The active window also can 
be changed to show a previously saved named display using the Display 
menu > Show Named Display command. A named display should not 
be confused with a named view, which only saves the view orientation 
and scaling, but not the contents of the window. 

Function Plots 
Function plots are graphs of one variable against another. These include 
the following: 

 Response-spectrum curves – These curves can be generated at 
any joint in the structure based on the results of a time-history 
load case. 

 Plot-function traces – These are general plots of any number of 
response quantities (displacements, stresses, and so on) against 
time or against another response quantity. These are available for 
any time-history or multi-stepped nonlinear static load case. 

 Static pushover curve – This is a plot of a single displacement 
measure against the base reaction for multi-stepped, 
displacement-controlled nonlinear static load cases. 

Function plots are displayed in a special plot window and may be 
printed. Tables of plotted values may also be printed or saved in a file. 

Tabular Displays 
Use the commands on the Display menu to show the model definition, 
analysis results, and design results as tabular data on screen. Choose the 
tables to be viewed. If objects are selected before tables are chosen, only 
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data for the selected objects are displayed. Otherwise results are 
produced for the entire model. 

Advanced options exist to control the format of the tables, to order and 
sort the data, and to create filters that will display only data that satisfy 
specified criteria. An example of this would be to display only frame 
design stress ratios that are above 0.9. 

Objects in the model may be selected from within a table form by using 
the Select menu. 

Tabular data also can be exported and printed from the on-screen 
displays using commands available on the File menu on the table forms. 

Designing 
Designing is used to check concrete, steel, cold-formed steel, and 
aluminum frame objects with respect to different design-code 
requirements. Design may be performed after the structure has been 
analyzed. Most design operations, including display, are available from 
the Design menu. 

Steel, cold-formed steel, and aluminum frame objects can have a 
minimum weight section automatically picked from a set of user-
specified sections. Concrete frame objects can have the area of 
longitudinal and shear reinforcing steel chosen automatically according 
to the selected design code.  

Individual members can be designed interactively, trying different 
sections and checking the results. If a section is changed manually, or if 
optimum sections were chosen automatically by the program, rerun the 
analysis and repeat the design process until the analysis and design 
sections are the same. 

Graphical displays of stress ratios and design parameters are available. 
Detailed design information can be obtained for single frame objects by 
clicking on them with the right mouse button. Alternatively, tabular 
design information can be displayed using commands on the Display 
menu and printed or exported using commands on the File menu. If 
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objects are selected before display, printing, or export, only selected 
objects are displayed, printed, or exported. Otherwise results are 
produced for the entire model. 

In addition to the code-based design offered for frame objects, non-code 
specific design stresses and tensile reinforcing may also be displayed for 
concrete shells. Unlike the frame objects, there are no explicit design 
settings under the Design menu for concrete shells. Instead, these design 
values are available from the Display menu, and are calculated based on 
a resolved tension-compression couple in the shell and the yield strength 
of the user specified reinforcing.  

Locking and Unlocking 
After an analysis has been performed, the model is automatically locked 
(except when using the Model-Alive analysis feature) to prevent any 
changes that would invalidate the analysis results and subsequent design 
results that may be obtained. The model also can be locked at any time to 
prevent further changes, or unlocked to permit changes. Lock and 
Unlock are accessed from the Options menu. 

If the model is unlocked after an analysis, SAP2000 will display a 
warning that all analysis results will be deleted. To save the analysis 
results, save the model under a different name before unlocking it. Any 
subsequent changes will then be made to the new model. 

Load cases can be defined without unlocking the model. New cases can 
be added, and cases that have not been run can be modified or deleted 
with no effect. If a case that has already been run is modified or deleted, 
analysis results for that case and all cases that depend on it will be 
deleted. 

Entering Numerical Data 
When entering data in a form, all numerical values by default use the 
units shown on the status bar. Some forms provide a units option directly 
on the form, which supersedes the setting on the status bar.  
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Different units can be specified directly when the numerical value is 
entered. For example, assume meter units were in effect, either from the 
status bar or the form itself. If “3500 mm” is entered, the value would be 
converted to 3.5.  

When force, length, or temperature units are mixed, list all units used, 
separated by commas or spaces, in the following order: force, length, 
temperature. For example, a modulus of elasticity (force/length2) could 
be specified as “30000 kip in,” and a moment (force-length) could also 
be specified as “30000 kip in.” Note that only the names of the units are 
needed, without indicating if they are multiplied, divided, squared, or so 
on. 

As a special case, length values can be entered in U.S. architectural units 
as feet and inches, as in the following example format: 9’-3”. The (’) for 
feet is required, but the dash (-) and the (”) for inches are optional. 

Formulas also can be used when entering data. For example, a data value 
can be specified as “1000+40” or as “100*sin(30).” If units are specified 
with a formula, be sure to leave a space after the formula before the 
units, e.g., “1000+40 m.” The formula is evaluated first before the units 
are applied, thus different units cannot be used in different parts of the 
formula. 

A complete calculator is available for more complicated entries. Double-
click on the numerical field while holding down the Shift key to access 
the calculator. Use the View menu > Show All command on the 
calculator form itself to review its full capabilities. 

Setting Options 
Many options can be set to control how the program behaves. These 
options are accessed using the Options menu, and include the following: 

 Dimensions and tolerances – merge, selection, and snap 
tolerances; font sizes; zoom increment; and others 

 Colors of objects and results for display and printing 

 Formatting for tabular data  
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 Display of the bounding plane 

 Other display options that affect all display windows 

 Locking and unlocking of the model 

Getting Help 
To access the SAP2000 Help facility, use the Help menu > Contents 
and Index command, or press the F1 key at any time. 

If a form is open, clicking the F1 key will display information about how 
to use that form. Otherwise the F1 key simply opens the Help facility, 
which allows the following: 

 Browse through the many topics using the Contents 

 Use the Index to display related Help topics 

 Use the Search feature to find topics that contain specific words 

From the Help menu, also access all SAP2000 documentation in Adobe 
Acrobat .PDF file format, or go to the CSI web site. 

The Help menu > About SAP2000 command will display the version of 
the program, as well as information about the computer’s operating 
system. This information is very useful when contacting CSI for 
technical support. 
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Chapter 5 
Working with Data Tables 

All SAP2000 data that can be accessed using the graphical user interface 
can also be accessed as tabular data, i.e., as data organized in a set of 
tables with specified table names and column headings. These data 
include the definition of the model and the results of analysis and design. 
Tabular data can be used for editing or display in the graphical user 
interface, for export to and import from other programs, and for 
generating printed output in a variety of formats. 

Classification of Tabular Data 
SAP2000 tabular data is divided into three distinct classes: model 
definition, analysis results and design results. 

Model Definition 
Model definition data include all components of the structural model 
(properties, objects, assignments, load patterns, load cases, design 
settings, and so forth), as well as any user-specified options and named 
result definitions.  
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Model definition data are always available, even if analyses have not 
been run or design has not been performed. These tables can be edited, 
displayed, exported, imported, and printed.  

Analysis Results 
Analysis results data include the deflections, forces, stresses, energies, 
and other response quantities that can be produced in the graphical user 
interface. These data are available only for load cases that have actually 
been run. Analysis results tables can be displayed, exported, and printed, 
but not edited or imported. 

Design Results 
Design results data include the design stresses, stress ratios, effective 
lengths, optimal sections, area of reinforcing steel, and all other 
calculated quantities resulting from the design process. These data are 
only available for objects that have actually been designed. Design 
results tables can be displayed, exported, and printed, but not edited or 
imported. 

Tables and Fields 
SAP2000 tabular data is organized into a set of prescribed (pre-defined) 
tables. Different tables exist for each of the three data classes. Each table 
has a prescribed name.  

Examples of model-definition tables are “Joint Coordinates” and 
“Connectivity - Frame.” Examples of analysis-results tables are “Joint 
Displacements” and “Element Forces – Frames.” Examples of design-
results tables are “Concrete Design 1 - Column Summary Data - ACI 
318-02” and “Steel Design 3 - Shear Details - AISC-LRFD99.” 

A prescribed set of field names is permitted for each table; the field 
names become the column headings in the tables. The columns may be 
arranged in any order, and not all fields are always required. Examples of 
field names for the “Joint Coordinates” table are “Joint,” “CoordSys,” 
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and “Z.” Associated with the column headings may be the units used for 
all data in that column. 

Data is entered into the table in one or more rows. Each row contains 
data in the same order as the field names (column headings).  

Figure 5-1 shows an example of the “Connectivity - Frame” table, with 
its nine fields “Frame,” “JointI,” “JointJ,” “IsCurved,” “Length,” 
“CentroidX,” “CentroidY,” “CentroidZ,” and “GUID.” The units used 
are shown with the column headings. Eleven rows of data are entered in 
the table, listing frame objects and the two joints to which they connect, 
as well as if the objects are curved. The calculated length and centroids 
of each object are also given.  

 
Figure 5-1 Example of a Database Table 

Uses for Tabular Data 
SAP2000 produces tabular data for three distinct purposes: 

 Object selection, i.e., selecting using records in a table 

 Uses for Tabular Data 5 - 3 



SAP2000 Getting Started 
 

 Formatted for presentation, i.e., for display and printing 

 Structured as a database for use and modification by computer 
programs 

Selecting using Tables 
Objects may be selected using SAP2000 data tables, allowing records to 
be sorted and filtered, and then selected. This is a powerful alternative to 
graphical selection and can be accessed through the Select menu or the 
Display menu. 

Formatted Tables for Presentation 
SAP2000 data tables can be displayed on-screen in the graphical user 
interface, or printable files of data tables can be generated in one of the 
following formats: 

 Rich text format for Microsoft Word  

 HTML format for Microsoft Internet Explorer  

 Plain (ASCII) text 

 Microsoft Excel (during on-screen display only) 

 Microsoft Access (during on-screen display only) 

The program provides complete control over how the tables are to be 
formatted, as described in the “Format Control for Display and Printing” 
section later in this chapter. 

For more information on generating formatted tables, see the “Displaying 
Tabular Data,” “Printing Tabular Data” and “Custom Report Writer” 
sections later in this chapter. 
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Structured Database Tables 
SAP2000 data tables can be displayed on-screen in the graphical user 
interface, or the structured tabular database files can be exported and 
imported in one of the following formats: 

 Microsoft Access database 

 Microsoft Excel spreadsheet 

 Plain (ASCII) text 

Unlike printable output, the format of these tabular database files is 
strictly controlled to allow SAP2000 and other programs to read the data. 

See the “Interactive Table Editing,” “Exporting Tabular Data” and 
“Importing Tabular Data” sections later in this chapter for more 
information on working with database tables. 

Displaying Tabular Data 
Available data can be displayed in tabular format at any time while 
working in the SAP2000 graphical user interface. Use the Display menu 
> Show Tables command to access model definition, analysis results, 
design results, or a mixture of all three classes of data. Figure 5-1 shows 
an example of a displayed table.  

For each class of data, choose specific types of data to determine which 
tables are displayed. Figure 5-2 shows the form used to select the type of 
data to be displayed, printed or exported. Each check box corresponds to 
one or more tables that will be used to display the chosen data. To 
choose the same set of tables repeatedly, save the settings as a named set 
that can be used later for displaying, printing, and other tabular data 
operations. 

If objects are selected before display, only the selected objects will be 
shown in those tables that contain object-specific data. Otherwise the 
entire model will be used. 
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While tabular data is being displayed, it can be printed directly to the 
default printer in plain text format. Also any of the following programs 
available on your computer can be used to open and view the tables: 

 Microsoft Word as rich text format 

 Microsoft Internet Explorer as HTML format 

 The default text editor as plain text 

 Microsoft Excel 

 Microsoft Access 

 
Figure 5-2 The Form Used to Select the Type of Data to Display, Print, or Export 
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The tables can be printed from these programs. However, any changes 
made to the tables using these programs cannot be brought back into the 
SAP2000 model while displaying data. See the “Interactive Table 
Editing” section later in this chapter for an explanation of how to edit 
tabular data. 

Options provide complete control over how the tables are to be 
formatted, as described in the “Format Control for Display and Printing” 
section later in this chapter.  

Note that, during display, Excel spreadsheet and Access database files 
can be created. However, it is not recommended that those files be 
imported back into the model because the formatting applied during 
display likely would result in errors when the file is imported. Thus, use 
the appropriate File menu > Export commands to create Excel 
spreadsheet and Access database files that will ultimately be imported 
back into the model. The Export commands include controls that reduce 
the likelihood of errors when files are imported back into the model. 

Printing Tabular Data 
Use the File menu > Print Tables command to print data tables directly. 
As described in the previous “Displaying Tabular Data” section, choose 
the type of data tables to be printed and optionally select a portion of the 
model to which object-specific tables should apply. 

Tables can be printed directly to the default printer in plain text format, 
or electronic files can be generated that can be opened and printed using 
any of the following programs: 

 Microsoft Word as rich text format 

 Microsoft Internet Explorer as HTML format 

 The default text editor as plain text 

The program provides options for complete control over how the tables 
are formatted, as described in the “Format Control for Display and 
Printing” section later in this chapter.  
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Creating a Report 
A complete, formatted report is available by simply using the File menu 
> Create Report command. This report contains a title page, 
hyperlinked table of contents, display of the structure, and tables 
showing the definition of the model, as well as selected analysis and 
design results, if available. Users can control the content and format of 
the report using the File menu > Report Setup command. This enables 
users to choose the type of file to produce (RTF, HTML, or text), the 
portion of the structure to be included, as well as to choose external files 
that control the detailed content and format of the report. The report is 
controlled by the report content file, which is an XML file that users can 
edit. A default report content file is supplied with SAP2000. If necessary, 
users may create their own files to suit the needs of their companies, 
projects, or approving agencies. Details of the report content file can be 
found using the Help menu > Documentation command. 

Advanced Report Writer 
Advanced Report Writer enables formatted reports to be created using 
tabular data from SAP2000, along with figures and text. Reports can be 
created in the following formats: 

 Rich text format for Microsoft Word  

 HTML format for Microsoft Internet Explorer  

 Plain (ASCII) text 

Use Advanced Report Writer to pull together tables from one or more 
database files, which can be from the same or different models.  

To prepare the report, enter section headings, arbitrary text between the 
tables, and pictures using many different file formats. The program also 
provides options to control the formatting of the tables, page setup, and 
fonts.  
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Format Control for Display and Printing 
SAP2000 has options for controlling the format of tables used for display 
and printing. 

Use the Options menu > Set Program Default Display Units command 
to specify the format desired for each type of numerical item in the 
program (e.g., forces, moments, lengths, and so forth). For example, use 
this command to specify that dimensions of the structure be displayed in 
feet (or meter) units with three decimal digits and that section 
dimensions be displayed in inch (or millimeter) units with one decimal 
digit. By default, the program will use the current units for all items, with 
built-in settings for numerical accuracy. 

In addition, use the Options menu > Database commands to control the 
detailed formatting of each column in each table, such as: 

 Which fields are present and in what order 

 Column widths and justification 

 Sorting of data, i.e., how the rows are ordered 

 Filtering of data, i.e., which records are included 

 Other advanced features 

An option can be used to save the format settings in a table formats file 
for later use. 

Note that database tables exported under the File menu do not use any of 
this formatting information, except that database tables in Excel format 
use the units specified using the Options menu > Set Program Default 
Display Units command.  

Interactive Table Editing 
Sometimes it is more convenient to create and edit model definition data 
in tabular format rather than in graphical mode or using standard forms. 
Edit model definition data in tabular format using the Edit menu > 
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Interactive Database Editing command. Only model definition data can 
be edited this way, and the model must be unlocked to use this feature. 

Choosing the types of data to edit determines the tables that are 
available. If objects are selected before using the Edit menu > 
Interactive Database Editing command, only data for the selected 
objects will be available in tables that contain object-specific data.  

Additions, deletions, or modifications can be made to the data in the 
selected tables. Those changes then can be applied to the model, or the 
table editing process can be ended without saving the changes. 

Numerical formulas (e.g., 2+3/4) can be typed directly into any cell. Also 
right-clicking within any field (column) will cause a useful pop-up menu 
to appear. That menu can be used to display a description of the field. If 
the field expects text-type input, then, in most cases, the menu also 
provides access to a drop-down list with all acceptable values for the 
selected cell. If the field expects numeric-type input, the menu provides 
access to the SAP2000 Calculator. 

While working on a table, change the units used for a given field by 
clicking on the cell just below the column heading. Changing the units 
for one field will change the units for other related fields. The units 
chosen while editing tables interactively are temporary. All values will 
be converted back to the current model units after the edited data has 
been applied to the model. 

Use the Excel > Send Database Table to Excel command on the SAP2000 
Interactive Database Editing form to send the current table to Microsoft 
Excel, where full spreadsheet functionality is available to edit the table. 
After editing the data in Excel, do not close Excel. Instead, return to 
SAP2000 and select the Excel > Retrieve Database Table from Excel 
command to save the changes or the Cancel Database Table in Excel 
command to discard them; Excel will automatically be closed. 

Exporting Tabular Data 
Normally, using the File menu > Save command will save a SAP2000 
model in a binary file with an .SDB extension. Analysis results, if any, 
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are saved in a set of binary files in the same folder. Those binary files 
form a database that is used when the File menu > Open command is 
used to open an existing model. They are in a format that is internal to 
SAP2000; the contents of those files can be accessed using the graphical 
user interface only. 

To provide external access to SAP2000 data, export the model definition, 
analysis results, and design results as a SAP2000 tabular database in any 
of the following file formats: 

 Microsoft Access database 

 Microsoft Excel spreadsheet 

 Plain (ASCII) text 

To export tabular data, use the appropriate File menu > Export 
command. Specific details of the different file formats are described in 
the “Tabular Database File Formats” section. However, they all use the 
same table names and field (column) names, and they all provide the 
same description of the SAP2000 data. 

When exporting, choose the classes of data to export and the types of 
data within each class; this, in turn, determines the tables that are 
exported. If objects are selected before exporting, only the data for the 
selected objects will be exported in those tables that contain object-
specific data. 

Any number of different files can be exported from a given SAP2000 
model. Each file may contain different tables and may apply to different 
parts of the model. Those files may be used for processing by other 
programs, for modification before re-importing to SAP2000, or for other 
purposes. However, to ensure that the exported file contains a complete 
description of the model, be sure to export all importable model-
definition data for the entire structure. 

Importing Tabular Data 
Use the File menu > Import commands to import model definition data 
as a SAP2000 tabular database from any of the following file formats: 
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 Microsoft Access database 

 Microsoft Excel spreadsheet 

 Plain (ASCII) text 

The data could have been exported from the SAP2000 graphical user 
interface, or created in some other way. Exporting a model, modifying it, 
and then re-importing the data is useful for parameter studies and for 
iterative shape-finding problems. Certain features can be exported from 
one model and imported into another model. 

Note that the format of an imported file must be consistent with the 
format used for exporting. To apply the appropriate format to files 
created outside SAP2000, first create a model in the graphical user 
interface, and then use the appropriate export command to generate the 
format that can be used as a template. See the “Tabular Database File 
Formats” section later in this chapter for more information.  

Data can be imported into a new model or added to an existing model. If 
the file is being imported into a new model, the file should include all 
importable information for a complete model. If a file is being added to 
an existing model, the file can consist of one or more tables.  

The “Program Control” table must always be present for the database to 
be imported (otherwise an error will occur). Thus, to import some new 
joints into an existing model, the file being imported could consist of 
only two tables, the “Program Control” table and the “Joint Coordinates” 
table. 

When adding to an existing model, choose how to handle conflicts 
between imported data and data that is already present in the model:  

 Keep the existing item and ignore the imported item. 

 Delete the existing item and use the imported item. 

 Keep the existing item and add the imported item with a new 
name. 

Some model definition data is importable, and some is not. For example, 
the coordinates of the joints are importable, as is the connectivity of the 
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frame objects to the joints. The lengths of the frame objects are included 
for informational purposes with the model definition data, but lengths are 
not importable since they can be calculated from the coordinates of the 
joints to which each object is connected.  

Automatic Export During Save 
Every time a SAP2000 model is saved, all model definition data is 
automatically exported as a tabular database in plain text format to a file 
with the a .$2K extension. This file is also created when an analysis is 
run, because the program always saves the model before running the 
analysis. 

The .$2K file serves as a text-file backup for the SAP2000 binary .SDB 
file. This file can be imported as an alternative to opening the .SDB file. 
Importing the .$2K file will not recover analysis or design results, only 
the complete model definition. 

Export During Analysis 
An option is available to request that model definition and analysis 
results tables be exported in Access database format every time an 
analysis is run. This can be particularly useful if a series of analyses is 
being run for different models using the SAP2000 batch-file option. 

To use this option, specify a previously defined named set of model 
definition tables and a named set of analysis results tables to be exported. 
Named sets are defined using the Define menu > Named Set command, 
or they can be defined while displaying or printing tabular data. 

Tabular Database File Formats 
Database tables can be formatted for Microsoft Access, Microsoft Excel, 
or a text editor. A tabular database in any of these formats will contain 
equivalent data. 
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The database table and field names in SAP2000 can be customized using 
the Options menu > Database commands. See the on-line Help facility 
in SAP2000 for more information. 

Microsoft Access Database 
Each SAP2000 table is written as a separate Access database table, with 
the SAP2000 field names as the column headings. All tables and fields 
use one consistent set of units, namely the current units in effect when 
the file is created. These units are stored in the “Program Control” table, 
not with the individual fields. 

Microsoft Excel Spreadsheet 
Each SAP2000 table is written as a separate worksheet in an Excel 
tabular database file. The SAP2000 field names are the column headings. 
The units associated with each field are displayed beneath the field 
names.  

For export to Excel, the units are the current units in effect when the file 
was created, unless different units have been specified using the Options 
menu >  Set Program Default Display Units command.  

For import from Excel, each field (column) may have a unique set of 
units.  For example, in the “Joint Coordinates” table, the X Coordinate 
could be imported in inches, the Y Coordinate in feet and the Z 
Coordinate in meters. Note that this does not apply for import from 
Access or plain text tabular databases, which use a consistent set of units. 

In Excel, the headers are color-coded. Fields that can be imported have 
yellow headers. Fields that are ignored upon import have cyan (light 
blue) headers. 

Plain Text File 
The Text File Database is always in one consistent set of units. These 
units are specified in the Program Control table. 
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The Text File Database consists of a series of tables. Each table has a 
series of one or more records (rows). Each record in the table must be on 
a single data line. A continuation character (a blank space followed by an 
underscore, i.e.,  _ ) can be used to indicate that a data line continues on 
to the next line of text in the file. 

Table names are specified by the keyword “TABLE:” followed by a 
space and the name of the table.  The record data lines for a table follow 
the table-name data line. A record data line consists of pairs of data; each 
data pair is made up of a field name followed by the field data. One data 
pair is required for each field in the table.  All data pairs for a given 
record must be on the same data line. 

The $ character is used as a comment character. Any data on a given data 
line that occurs after a $ is ignored by the program on import. 

Blank lines may occur anywhere and are completely ignored on import. 
Also, any data occurring before the first table-name data line is ignored. 
The program will stop reading the file when it encounters the “End” 
keyword. 

When SAP2000 creates a Text File Database, the field data is always 
enclosed in quotation marks, whereas the field names are not in quotation 
marks. The quotation marks have no significance; they are provided to 
make the text file easier to read. Text files can be created with or without 
quotation marks. 

By watching the status bar in the bottom left of the SAP2000 window 
while importing a text file, you may notice that the text file is first 
transferred to a Microsoft Access file and then the Microsoft Access file 
is imported into SAP2000. 

More Information 
Detailed information on using the various menu commands and forms is 
available using the online Help facility in the SAP2000 graphical user 
interface. 
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Complete documentation for any or all tables and fields can be produced 
using the Options menu > Database > Documentation to Word 
command, which creates a Microsoft Word document that can be opened 
and printed. 
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